commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland Kofler <roland.kof...@systemone.at>
Subject Re: [CLI] noob: why command history on linux doesn work, on windows does
Date Sat, 28 Oct 2006 21:18:33 GMT

no i use bash, I've verified , with banshee in the start script and all, but
when I press arrow up ig only get ^[[A on the command line. tried on two not
customized debian servers, should <CRTL>+R also work? only Ctrl+j for new
line worked. on the "real" shell everything its fine. 
how do you interface to the shell from java? is there an interface in j2se
or how its done?

Thanks!
Roland



Marc Carter wrote:
> 
> Rolans,
> 
> Unless I misunderstand the question -- the answer is [c].  Command line 
> history on Linux is a feature of the shell you are using.  If you are 
> using the (pretty universal) bash shell then up-arrow does indeed work 
> just as in Windows.  If you have another shell then you will need to read 
> the man pages.
> 
> On my machine "echo $SHELL" prints "/bin/bash"
> 
> Marc
> 

-- 
View this message in context: http://www.nabble.com/-CLI--noob%3A-why-command-history-on-linux-doesn-work%2C-on-windows-does-tf2531019.html#a7054742
Sent from the Commons - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message