commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Novotny <novo...@gridsphere.org>
Subject Re: using commons-logging in webapp w/ log4j, can't find my properties
Date Sat, 14 Oct 2006 18:32:56 GMT

    Thanks-- I'm using Tomcat 5.5.17... I guess one question is how do I 
log the logger? There must be some way to see where it is looking for 
the appropriate properties file. I imagine that commons-logging classes 
can see the log4j classes in the same classpath and then start looking 
for the properties file in a few places...

    Thanks, Jason

Dennis Lundberg wrote:
> Jason Novotny wrote:
>>
>> Hi,
>>
>>    I have a webapp and I have deployed common-logging-1.1 jar and 
>> log4j-1.2.11 in my WEB-INF/lib directory of my webapp. I have also 
>> place a log4j.properties file in my WEB-INF/classes directory. 
>> However, when the webapp runs, I see only INFO level is being logged. 
>> It all worked fine when I placed some line of the form
>>
>> PropertyConfigurator.configure(url);
>>
>> which forces a log4j to use the supplied config file, however I 
>> didn't think this was necessary--
>>
>> Any help is greatly appreciated!
>>
>>    Thanks, Jason
>
> Hi Jason
>
> We have been using a setup just like yours on Tomcat for a long time. 
> Recently we switched from log4j.properties to log4j.xml and just place 
> the xml file in WEB-INF/classes as well.
>
> What container are you running your application on?
>


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message