commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From van...@webmail.co.za
Subject Re: [net] Using FTPClient [was: Re: commons-vfs - Using FTPClient]
Date Mon, 02 Oct 2006 10:54:40 GMT
Great! Got it sorted out...it was the firewall
not being able to handle a active FTP session.

Thaks alot!


> Hi!
>> This is what the output displays.... message 425 takes about 20
>> seconds to display... Can anyone help me with this? Thanks!!!!
>>
>
>> //OUTPUT
>> 230 Login successful. Have fun.
>>
>> 425 Failed to establish connection.
>>
>> 221 Goodbye.
>>
>
> For me this is a problem with your (or the other side) firewall
> configuration.
> Sometimes a firewall do not support "active" ftp connections.
> You can try to use f.enterLocalPassiveMode() (or so, sorry, I do not
> remember the correct syntax yet).
> This way commons-net will try to use passive ftp data connections which
> might have more success bypassing a firewall.
>
> But ... this has nothing to do with commons-vfs, do you try to use
> commons-net through commons-vfs (using a ftp filesystem)?
> Then there is a FtpFileSystemConfigBuilder which allows you to
> setPassiveMode(opts, true).
> If you need more support with this, just ask again.
>
> Ciao,
> Mario
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>



-------------------------------------------
For super low premiums, click here http://www.webmail.co.za/dd.pwm


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message