commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "robert lazarski" <>
Subject Really stuck on NoClassDefFoundError org/apache/commons/logging/LogFactory
Date Wed, 21 Jun 2006 22:40:55 GMT
Hi all,

I've been googling all day and I'm stuck. I'm trying to run a junit
test case in eclipse 3.1 calling an axis2 web service running in
jboss, that depends on HttpClient. I get this stack trace:

java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
	at org.apache.commons.httpclient.HttpClient.<clinit>(
	at org.apache.axis2.transport.http.AbstractHTTPSender.getHttpClient(
	at org.apache.axis2.transport.http.SOAPOverHTTPSender.send(
	at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(
	at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(
	at org.apache.axis2.engine.AxisEngine.send(
	at org.apache.axis2.description.OutInAxisOperationClient.send(
	at org.apache.axis2.description.OutInAxisOperationClient.execute(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at junit.framework.TestCase.runTest(
	at junit.framework.TestCase.runBare(
	at junit.framework.TestResult$1.protect(
	at junit.framework.TestResult.runProtected(
	at junit.framework.TestSuite.runTest(
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(

I'm running 1.04, but tried to upgrade to 1.1 with no luck. I tried
butting the commons.logging jar under jdk1.5.0_03/jre/lib/ext - no
luck. I tried this, still no luck:

    protected void setUp() throws Exception {

I'm out of ideas. Any help very much appreciated. I just need this
junit test case to run in eclipse.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message