commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bradley, Todd" <todd.brad...@Polycom.com>
Subject cr vs. no-cr in Commons Net TelnetClient
Date Fri, 09 Jun 2006 19:09:56 GMT
Hi, I'm using the Commons Net TelnetClient to write an interface to a
network device.  This device can be queried and programmed remotely
through telnet, and I've got most of it working.  However, the response
to every command you give this device ends with a carriage return (but
no linefeed).  

When I run my app on Windows XP, this carriage return is passed on
through to the TelnetClient's input stream, where I can detect it to
tell that the device is finished responding to my app.  

But when I run my app on Linux, I don't get the carriage return.  And so
I have no way of knowing when the device has finished responding.  I'm
guessing this may have something to do with line termination characters,
and maybe Commons Net is filtering them differently on the different
platforms.

Anyone have any advice on how I can make TelnetClient work the same on
Linux as on Windows?


Thanks,
Todd.
----
Todd Bradley - Polycom, Inc.
Test Lead, Proximo Projects

Visit me at my WebOffice for IM and app sharing:
http://www.polycomweboffice.com/todd.bradley@polycom.com 

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message