commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randall S Horwitz <>
Subject Configuration-exception newing up XMLConfiguration empty constructor
Date Tue, 02 May 2006 18:45:03 GMT

I recently downloaded Commons Configuration 1.2. I then tried to write a 
simple class in which I simply wanted to new up an XMLConfiguration 
object. Here is part of the code. My little test program compiles, but 
will not run:

import org.apache.commons.configuration.XMLConfiguration;
System.out.println ("newing up config class") ;
XMLConfiguration config = new XMLConfiguration() ;
System.out.println ("Commons class newed up") ;

I see the first pprint out, but not the second, and I get the following 

Exception in thread "main" java.lang.NoClassDefFoundError: 
        at java.lang.J9VMInternals.verifyImpl(Native Method)
        at java.lang.J9VMInternals.verify(
        at java.lang.J9VMInternals.verify(
        at java.lang.J9VMInternals.verify(
        at java.lang.J9VMInternals.verify(
        at java.lang.J9VMInternals.initialize(
        at CommonsTest.main(

I am using JDK 1.5, Windows XP, and I've ensured that 
commons-configuration-1.2.jar is on my user classpath. What am I doing 
wrong? I am using similar code as in in the XML Configuration Howto.


Randy Horwitz
IBM Human Ability & Accessibility Center
Phone: (512) 838 8416
Tie Line (internal to IBM): 678 8416

"It is the easy things that damn you, not the hard."
-- Joseph R Garber "Vertical Run"

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message