commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stella Huh" <>
Subject Problem creating array descriptor
Date Fri, 12 May 2006 01:02:15 GMT
I googled this problem and no solution was found. I'm trying to pass in an array to a pl/sql
procedure through JDBC, and here's what I have in the java code: (dconn = org.apache.commons.dbcp.PoolingDataSource$PoolGuardConnectionWrapper)

          DelegatingConnection dconn =(DelegatingConnection) ((BasicDataSource) getJdbcTemplate().getDataSource()).getConnection();
          System.out.println("dconn = " + dconn.getClass().getName());
          ArrayDescriptor stringDescriptor = ArrayDescriptor.createDescriptor( "PACE_MASTERDBO.STRING_ARRAY",
dconn.getInnermostDelegate() );

I also tried ((DelegatingConnection) con).getInnermostDelegate(), where con is of type java.sql.Connection,
but got the same result.

I get the following error at the ArrayDescriptor line:
java.sql.SQLException: Fail to construct descriptor: Invalid arguments
        at oracle.jdbc.dbaccess.DBError.throwSqlException(
        at oracle.jdbc.dbaccess.DBError.throwSqlException(
        at oracle.jdbc.dbaccess.DBError.check_error(
        at oracle.sql.ArrayDescriptor.createDescriptor(

I've been working on this for some time now and would greatly appreciate your help.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message