commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank W. Zammetti" <fzli...@omnytex.com>
Subject {Validator] Problem parsing validation.xml
Date Thu, 06 Apr 2006 04:40:34 GMT
Hello... I'm playing with Validator a bit, and I'm having a problem I've
never seen before... I'm getting the following exception:

SEVERE: Parse Error at line 1 column 17: Document root element
"form-validation", must match DOCTYPE root "null".

This would seem to be saying it expects a doctype, but I've never seen an
example showing a doctype in validation.xml.  Can anyone shed some light
on this for me?  I have this entry in struts-config.xml:

  <plug-in className="org.apache.struts.validator.ValidatorPlugIn">
    <set-property property="pathnames"
value="/WEB-INF/validator-rules.xml,/WEB-INF/validation.xml" />
  </plug-in>

And I have the validator-rules.xml pulled out of the Struts 1.2.9 distro,
and here is validation.xml:

<form-validation>
  <formset>
    <form name="testForm">
    </form>
  </formset>
</form-validation>


I *did* have a formset and all defined, but I figured let me back up a
step and see if just this will work.  testForm is a properly configured
DynaValidatorForm by the way.  Thanks!

-- 
Frank W. Zammetti
Founder and Chief Software Architect
Omnytex Technologies
http://www.omnytex.com
AIM: fzammetti
Yahoo: fzammetti
MSN: fzammetti@hotmail.com
Java Web Parts -
http://javawebparts.sourceforge.net
Supplying the wheel, so you don't have to reinvent it!



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message