commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mornak <dmorna...@gmail.com>
Subject Re: [betwixt] attributes inside list items
Date Fri, 07 Apr 2006 20:43:49 GMT
I think it is the same problem that I answer a minute ago in this list

i am copying the message




From: Mornak <dmornacco@gmail.com>
Date: Apr 7, 2006 5:40 PM
Subject: Re: [betwixt] attributes disables a element ?
To: Jakarta Commons Users List <commons-user@jakarta.apache.org>


You are right! the attribute disbles the content

If you want to read both of them you youl use the tag text

Something like this
<element name="list">
        <element name="id">
                <attribute name="recipient" property="recipient"/>
                <text property="id" />
        </element>
</element>

When i tried this with the 0.7 release it didn't work. I got a
nightbuild and it worked fine

I hope this will help you

PD: excuse my terrible english




On 4/7/06, denis queffeulou <denis.queffeulou@wokup.com> wrote:
> Hi,
>
> I have the following betwixt :
>
>                     <element name="list">
>                         <element name="id" property="id"/>
>                         <!--
>                             <attribute name="recipient"
> property="recipient"/>
>                         </element>
>                         -->
>                     </element>
>
> With comment, I can retrieve the id property from XML,
> but if I add the attribute "recipient", then I get a *null* "id" and a
> good "recipient".
>
> The XML is
>           <list>
>             <id recipient="089786756">8090</id>
>           </list>
>
>
> I don't undertsand why this doesn't work with the attribute ??
> --
> Denis
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>




On 4/7/06, denis queffeulou <denis.queffeulou@wokup.com> wrote:
> Hi ,
>
> I'm using a bean that contains a list of String (items) and a
> getMessageId() method.
> I have the following betwixt:
>
>                 <element name="list">
>                     <element name="item" property="items">
>                         <attribute name="attr1" value=""/>
>                         <attribute name="attr2" property="messageId"/>
>                     </element>
>                 </element>
>
> and I hope get the following XML :
>
> <list>
>     <item attr1="" attr2="somevalue of main bean"/>
>     <item attr1="" attr2="somevalue of main bean"/>
> ...
> </list>
>
> but I got:
> <list>
>     <item>some value</item>
>     <item>some value</item>
> ...
> </list>
>
> It seems that attributes are not processed ??
>
> anyone knows why ?
> --
> Denis
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>


--

To Iterate is Human, to Recurse, Divine
 - James O. Coplien, Bell Labs

-------------------------------------
<EPI/> - Deploying ideas
-------------------------------------
Ing. Diego H. Mornacco
Desarrollador
Epidata Consulting
MaipĂș 521 1er piso Of. A
Ofi: 5031 0060 / 61
Cel: 15-5884-0040
www.epidataconsulting.com

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message