commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Hufgard <christian.hufg...@gmx.de>
Subject Re[2]: [DBCP] Problem when hosting live
Date Sat, 07 Jan 2006 11:41:46 GMT
Think this might be exactly the problem we had.

Tomcat 5.0 uses another way to configure datasources. In this versions
datasources are defined with

 <Resource name="jdbc/TestDB"
               auth="Container"
               type="javax.sql.DataSource"/>

  <ResourceParams name="jdbc/TestDB">
    <parameter>
      <name>factory</name>
      <value>org.apache.commons.dbcp.BasicDataSourceFactory</value>
    </parameter>
    ...
  </ResourceParams>

Tomcat 5.5 uses the following format:

  <Resource name="jdbc/TestDB" auth="Container"
  type="javax.sql.DataSource" .../>

  
Did you check this allready?

Christian

Saturday, January 7, 2006, 12:30:49 PM, you wrote:

> Hi Christian,
> Our development server is Tomcat 5.0.28, and the hosting comapny uses
> Tomcat 5.5.7
> However, we don't use Apache as a webserver (just Tomact), and the 
> hosting company uses Apache 3.3?
> If I can provide any other information that might help, please let me know.
> Thanks,
> Martin


> Christian Hufgard wrote:

>>Hi Martin,
>>
>>I saw exactly the same problem two days ago. :) What Tomcat versions
>>are running on your servers? Our problem was, that we tried to install an
>>application that was running fine on Tomcat 4.x onto a Tomcat 5.5.x
>>and missed that the way datasource are configured was changed.
>>
>>Christian
>>
>>Saturday, January 7, 2006, 10:58:57 AM, you wrote:
>>
>>  
>>
>>>Hi all,
>>>Some time ago, I was looking for help with getting started on Connection
>>>Pooling. Well, we got the problem sorted on our development server, but
>>>when we move to a live hosting server (shared Tomcat), it's a different
>>>story. We keep getting a message
>>>    Cannot create JDBC driver of class '' for connect URL 'null'
>>>We have made sure all the JAR files necessary for connection pooling are
>>>available in the CATALINA_HOME/common/lib directory and all the settings
>>>on our web.xml and context.xml files seem to be in order.
>>>If anyone can point us in the right direction, we would be really 
>>>grateful. We really need to have the hosting problem sorted out straight
>>>away.
>>>Many thanks,
>>>Martin
>>>    
>>>
>>
>>
>> 
>>  
>>
>>>------------
>>>Martin Grogan
>>>Keizen Software
>>>    
>>>
>>
>>  
>>
>>>mgrogan@keizensoftware.com
>>>www.keizensoftware.com
>>>    
>>>
>>
>>
>>  
>>
>>>---------------------------------------------------------------------
>>>To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
>>>For additional commands, e-mail:
>>>commons-user-help@jakarta.apache.org
>>>    
>>>
>>
>>
>>
>>  
>>

> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
> commons-user-help@jakarta.apache.org



-- 
Best regards,
 Christian                            mailto:christian.hufgard@gmx.de


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message