commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ghislain Bourassa <>
Subject Commons NET: FTP & VFS: Setting the last modification time: Bug report?
Date Tue, 01 Nov 2005 16:00:44 GMT
I have tried to change the last modification time of a file using the
VFS library through a FTP provider.
It had no effect on the time stamp of the file.
I also tried to do it using the FTP library directly.
It had no effect neither.
More specifically, it doesn't report any error, but the job is not
done on the server.
My question is the following: Is the setLastModificationTime method
really implemented?
Has anyone been able to change the last mod time using the FTP lib?
Or have you got any problem doing it?
I have tried it on many FTP servers Unix, Solaris, Linux: none worked.
By the way, if you call getLastModificationTime right after a call to
setLastModification time, it returns the right value, but it's a
cached answer, not the actual modification time of the file on the
Thanks for your help.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message