commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <ma...@ops.co.at>
Subject Re: [vfs] filecontent
Date Mon, 10 Oct 2005 15:18:33 GMT
Torsten Curdt wrote:
>> ExifService exif = (ExifService) fileObject.getService 
>> (ExifService.class);
>> int width = exif.getWidth(); 
>
> Hmm... I don't like the name "service" in this context.
Its used e.g. to implements SVN stuff like "update, commit, ..." (this 
is what the waiting contribution do)

> What about "view"? You provide a special view on the content.
A service it not necessary related to the content.

> ...maybe a bit more abstract - what about "aspect" ?
Sure, "aspect" might fit.
I will think of it.


---
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message