commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jjrob...@lexmark.com
Subject [daemon] Crash on service Start - does this look familiar?
Date Thu, 15 Sep 2005 15:47:22 GMT
Also, is anything logged during service startup other that what's in the
Event Viewer ?

----- Forwarded by J. Jeff Roberts/Lex/Lexmark on 09/15/2005 11:46 AM -----
|---------+---------------------------->
|         |           J. Jeff Roberts  |
|         |                            |
|         |           09/15/2005 11:45 |
|         |           AM               |
|         |                            |
|---------+---------------------------->
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                                                           |
  |       To:       commons-user@jakarta.apache.org                                      
                                                           |
  |       cc:                                                                            
                                                           |
  |       Subject:  [daemon] Crash on service Start - does this look familiar?           
                                                           |
  >--------------------------------------------------------------------------------------------------------------------------------------------------|



I'm trying to use procrun.exe (Tomcat5.exe from Tomcat 5.5.9 actually) to
wrap my own class as a service.

I'm passing pretty much the same parameters that I've used to start Tomcat
from a custom installer, so I'm not sure what I could be missing:

   procrun //IS//ApacheAgent --Startup=auto --LogLevel debug
   --DisplayName="Lexmark Solutions Apache Agent" --Jvm="C:\Program
   Files\Lexmark\Solutions\jre\bin\client\jvm.dll" ---Classpath="C:\Program
   Files\Lexmark\Solutions\ApacheAgent\lib\framework-1.0.jar";"C:\Program
   Files\Lexmark\Solutions\ApacheAgent\lib\log4j-1.2.8.jar";"C:\Program
   Files\Lexmark\Solutions\ApacheAgent\lib\firebirdsql-full.jar";.;
   --JvmMs=512 --JvmMx=512 --StdError=auto --StdOutput=auto
   --LogPath="C:\Program Files\Lexmark\Solutions\ApacheAgent\logs"
   --StartMode=jvm
   --StartClass=com.lexmark.workflow.framework.tools.ApacheAgent
   --StartParams=harvest.mw.prtdev.lexmark.com;9705 --StopMode=jvm
   --Install="C:\Program Files\Lexmark\Solutions\ApacheAgent\procrun.exe"

I get no errors when I create my service, but when I try to start it, I get
an access violation here:

   PROCRUN! 004042c5()
   e87c809a()

Does this crash look familiar to anyone?

-Jeff




---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message