commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Duff <david.d...@planetzorbo.co.uk>
Subject Re: [Validator] IllegalStateException: getReader() and getInputStream() called
Date Mon, 12 Sep 2005 16:01:57 GMT
Sorry, not too sure what you mean.  If you mean the controller is trying
to read a value from the query string to determine where it goes, it
doesn't do that.  If that isn't what you mean then could you explain please?

I use a web framework (maverick).  When the application comes into the
controller, it can't get the parameters yet (multipart) until my
startUpload() method gets the form parameters.  After this I can
validate my input so I have an conditional statement that checks the
form to see if it gets all the fields specified in the validator.xml. 
If it doesn't validate, it prints out a log message and returns to a
"failed" view, which points to the previous controller that brought up
the form.  The view is specified in the configuration xml file for
maverick under the command name.

Is this any more help to you?

Thanks in advance
David


Aaron Sheffey wrote:

>If the controller is trying to use the referer from the HTTP headers to 
>determine where to go back to, that could be the source of your problem.
>
>
>
>
>David Duff <david.duff@planetzorbo.co.uk> 
>08/30/2005 12:06 PM
>Please respond to
>"Jakarta Commons Users List" <commons-user@jakarta.apache.org>
>
>
>To
>commons-user@jakarta.apache.org
>cc
>
>Subject
>[Validator] IllegalStateException: getReader() and getInputStream() called
>
>
>
>
>
>
>Hi,
>
>I have a multipart form, which I would like to validate using
>validator.  My problem is that the application will fall over with the
>above exception when I try to return the application back to the page if
>a form validation error has occurred.
>
>The error occurs when the controller is trying to forward to the view
>"failed", which returns the application back to the previous
>controller.  It should then allow the user to view the page with the
>error messages on it.
>
>I have read various posts on the net about setting character encoding to
>fix the problem also about patching application servers and a bug in
>commons-file upload but nothing definitive or concrete.
>
>Can anyone help me?
>
>Has anyone had this problem before?
>
>Thanks in advance.
>
>David
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>
>
>  
>
>------------------------------------------------------------------------
>
>No virus found in this incoming message.
>Checked by AVG Anti-Virus.
>Version: 7.0.344 / Virus Database: 267.10.17/84 - Release Date: 29/08/2005
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message