commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Katharina Dammeier <Katharina.Damme...@in-gmbh.de>
Subject AW: [FileUpload] FileUpload doesn't work with IE but with Firefox
Date Fri, 19 Aug 2005 14:09:51 GMT
***********************
No virus was detected in the attachment (no filename).

Your mail has been scanned by Trend Micro InterScan.
***********************


When I get the empty page from IE, my application is not called ( I dont'
get logs, and I have
a lot).

The errorPage is from the IE 'this page cannot be shown', 'Server or dns
cannot be found'



-----Urspr√ľngliche Nachricht-----
Von: Brian Cook [mailto:bcook@printtime.com]
Gesendet: Freitag, 19. August 2005 15:58
An: Jakarta Commons Users List
Betreff: Re: [FileUpload] FileUpload doesn't work with IE but with
Firefox



If you debug this a little deeper wither using your IDE or marking each
step in the process with system.out.println("") methods I am betting you
will find this does not relate to commons.FileUpload.

Are you seeing any exceptions thrown in catalina.out?  Is the error seen
in the browser an IE default error, or a Tomcat error page?

The only difference I am aware of with IE is that it has an irritating
habbit under specific situations of returning the entire system path as
the file name.  You can simply get around this with an extra method call
like :

private String getRealFileName(String itemName) {

	int pointer = itemName.lastIndexOf("\\");

         if( pointer != -1){itemName = itemName.substring(pointer+1);}

         return itemName;
}


P.S.  You will get more responses to your posts if you follow the guide
lines posted at :

http://jakarta.apache.org/site/mail.html

Katharina Dammeier wrote:
> ***********************
> No virus was detected in the attachment (no filename).
>
> Your mail has been scanned by Trend Micro InterScan.
> ***********************
>
>
> hi,
>
> I have a Fileupload (enctype multipart-formdata) and it does work fine
with
> Firefox.
> But if I use IE, it mostly works by the first upload. If I want to make a
> second upload later, it doesnt' work, I get a wihte page "cannot be shown"
>
> Does anybody know anything about this problem and how to solve it?
>
> Thanks!
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>


--
Brian Cook
Digital Services Analyst
Print Time Inc.
bcook@printtime.com
913.345.8900



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message