commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grant Ingersoll" <>
Subject [CLI] IBiblio versus Apache Website
Date Wed, 13 Jul 2005 17:12:18 GMT
I am having a weird discrepancy in CLI that is causing a bug in my

I am in the process of converting my projects to Maven.  In doing so, I
specified my commons-cli dependency as:

Everything downloaded from IBiblio
( fine, or so I thought.

Upon doing so, though, tests that ran fine before now don't work. 
Before switching to Maven, I was building against a version of CLI I
downloaded from the Apache mirrors
After pulling my hair out for I while (and debugging to isolate it in
CLI), I tried switching my CLI implementation from the Maven version to
the Apache download and it all worked again.  The bug seems to have to
do w/ an option where hasArgs is true

Upon further inspection of the Jars, which both claim to be 1.0, I
noticed that the IBiblio one is 32k while the Apache one is 30k.  The
30k one works, the 32k one does not.

Does anyone know why they are out of synch and how to remedy this?  I
_believe_ I can extract my code to reproduce the bug if the IBiblio one
in fact is the correct one.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message