commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Bowen <s...@yahoo.com>
Subject DBCP :: Problem initializing pool
Date Mon, 27 Jun 2005 09:53:39 GMT
Hello everyone.

I am using DBCP (with Torque) for my J2EE app. I
believe I have a connection leak somewhere and I am
trying to find out where. When I try to initialize the
pool with parameters for dealing with and debugging
abandoned connections, I am getting errors with the
following params:

Property: removeAbandoned, Value: true
Property: logAbandoned, Value: true
Property: removeAbandonedTimeout, Value: 300

The error is always the same: "<param> value: <value>
is not supported by DataSource:
org.apache.commons.dbcp.datasources.SharedPoolDataSource

All three of these parameters appear on the DBCP
Configuration page
(http://jakarta.apache.org/commons/dbcp/configuration.html).


I believe I have all the correct versions of all jars:

commons-beanutils-1.7.0
commons-dbcp-1.2.1
commons-pool-1.2
commons-collections-3.0
commons-configuration-1.1

... but it doesn't want to work. The method that craps
out is in AbstractDataSourceFactory, setProperty().
Line 147:

Class propertyType = PropertyUtils.getPropertyType(ds,
property);

propertyType is always null.

Can anyone give me a hand with this? It seems that the
SharedDataSourceFactory doesn't allow these params,
but according to the documentation it does. Any ideas?

Many thanks,
syg






		
____________________________________________________ 
Yahoo! Sports 
Rekindle the Rivalries. Sign up for Fantasy Football 
http://football.fantasysports.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message