commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rkrue...@unit-medienhaus.de
Subject Re: procrun as user
Date Mon, 25 Apr 2005 10:44:08 GMT
Hi all,

Mark Kikken <mki@vaessen-consulting.de> wrote on 25.04.2005 11:39:10:

> Hi Guys,
> I'm actually trying this with the tomcat binary. It's really tomcat I'm
> trying to register as a service, for an IzPack installation of a portal
> application. So, I didn't run into the compillation problems you ran
> into. Maybe you should try it with the tomcat5.exe binary that comes
> with tomcat.

Yep, I tried exactly that, but couldn´t get it running :-(

> But still, I can't run the service as a different user. What could be
> causing this?

Hmm, I know that there´s the "Monitor Tomcat" tray icon program that
ships with tomcat since 5.0.x ....
There´s a configure option to have tomcat running as a special user
and not as SYSTEM. The user I had choosen for that belongs to the
administrator´s group.
I have already done this and it worked. ASFAIK the credentials put in
there are just passed to procrun. So it should work that way.

I used JDK 1.4_02 -> 1.5.x on Windows XP Professional with tomcat
5.0.28, 5.5.4 or 5.5.7 - don´t remember exactly.

Do you see some tomcat-related entries in the system´s event log?

Maybe you´re encountering the same or a similar problem that I was 
running into!?!


kind regards
Rolf


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message