commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kenneth Stephen <marvin.the.cynical.ro...@gmail.com>
Subject [Net]Commons depends on 1.4 JRE as of v1.3.0
Date Wed, 29 Dec 2004 22:59:47 GMT
Hi,

    On the jakarta site, a statement is made that Commons Net is
compatible with the 1.2 Java platform. However, as of v1.3.0, the
sendCommand(String, String) method in org.apache.commons.net.ftp.FTP
has the following snippet of code in it :

        catch (SocketException e)
        {
            if (!isConnected() || _socket_ == null || !_socket_.isConnected())
            {
                throw new FTPConnectionClosedException("Connection
unexpectedly closed.");
            }
            else
            {
                throw e;
            }
        }

    The problem is that _socket_ is an instance of java.net.Socket and
this class does not have an isConnected() method until the 1.4 Java
level. Hence this code will no longer compile with the 1.3 JDK. Is
there any plan to fix this, or is the backward compatibility statement
no longer true?

Thanks,
Kenneth

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message