commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert burrell donkin <robertburrelldon...@blueyonder.co.uk>
Subject Re: [betwixt] Betwixt version and conflict with log4j
Date Mon, 25 Oct 2004 21:27:06 GMT
hi henry

hmmm....

i'm not convinced that this is a log4j issue. (the only possibility 
which springs to mind is that you need to make sure you've upgraded to 
commons-logging 1.0.4 if you're using the latest series of log4j 
releases.)

please try to latest code from CVS (i fixed a classcast which sounds 
similar to this recently). if you still have the problem, then if you 
supply a unit test i'll take a look and debug it. at the very least, i 
might be able to take a guess at the cause if you can supply a stack 
trace.

BTW the alpha is still available from the mirrors 
(http://apache.rmplc.co.uk/jakarta/commons/betwixt/binaries/, for 
example) but it's very old and unsophisticated. i'd strongly recommend 
sticking with the latest release.

- robert

On 23 Oct 2004, at 01:44, Henry Cho wrote:

> I have a problem using Betwixt 0.6 with log4j.  I get a
> ClassCastException in
>
> org.apache.commons.betwixt.io.read.ReadContext.getCurrentElement() when
> it fires
>
> the final end() event.
>
>
>
> Is there any way to get the Betwixt 1.0 alpha release?  Perhaps this
> will fix my problem.
>
>
>
> Thanks,
>
> Henry
>


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message