commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ronald Dauster <...@ronald-dauster.de>
Subject Re: [DBUtils] Setting NULL values [was: SQL Server null]
Date Thu, 08 Jul 2004 14:01:33 GMT
David Graham wrote:

>Thanks for the testing!  Which of the 4 columns did you try to insert null
>into?  
>
All three simultaneously, but for Oracle I've also tried individual columns

>In my testing, Oracle worked with INTEGER but maybe it was a
>  
>
The problem is with the DATE column, probably because there's no 
conversion from INTEGER
to DATE. The error is ORA-00932 and it's the 
PreparedStatement.executeUpdate that fails
(in contrast to Types.OTHER, where the PreparesStatement.setNull throws 
an exception).

 Types.INTEGER works for VARCHAR2 and NUMBER columns.

Driver and database are both version 9.2.0.1.0

>different driver version.  It looks like we'll have to babysit Oracle and
>use VARCHAR.  Please let us know the results of SQL Server and Oracle 10.
>
>David
>  
>
Ronald

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message