commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk Verbeeck <dirk.verbe...@pandora.be>
Subject Re: [DBCP] Encoding Problem
Date Sun, 04 Jul 2004 18:14:47 GMT
Try

<parameter>
     <name>connectionProperties</name>
     <value>characterEncoding=UTF-8;useUnicode=true</value>
</parameter>

-- Dirk


Damian Minkov wrote:

> I'm using  Tomcat 4.1.30 on Debian machine.
> Version of DBCP -
>     libcommons-dbcp-java_1.0-4_all.deb
> 
> Have a web application in which I'm using Hibernate.
> But when I have configured  to use DBCP for connections which Hibernate
> uses
> I have problem with encoding ( for retrieving data and for inserting
> data in mysql )
> but with hibernate using direct connecting there is no problem.
> 
> I'm using connection parameters for mysql :
> characterEncoding=UTF-8
> useUnicode=true
> 
> there are set in Hibernate config ( when I try with hibernate direct 
> connecting to DB)
> 
> And described for DBCP
>     <parameter>
>         <name>characterEncoding</name>
>             <value>UTF-8</value>
>     </parameter>
>     <parameter>
>         <name>useUnicode</name>
>         <value>true</value>
>     </parameter>
> 
> I've also tried putting parameters in the Connection URL
> jdbc:mysql://10.1.1.2/nadia?useUnicode=true;characterEncoding=UTF-8
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
> 
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message