commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert burrell donkin <robertburrelldon...@blueyonder.co.uk>
Subject Re: [logging] Logging problems with log4j
Date Mon, 21 Jun 2004 21:08:42 GMT
hi

i don't know of any particular problems with websphere 5.1 (does anyone  
else?) but classpath issues are common in containers. you might have  
more luck using an alternative configuration mechanism such as the jdk  
1.3 jar service discovery mechanism.

if you really want to use this commons-logging.properties file  
mechanism then it's possible that if websphere has a version of  
commons-logging in it's root classloader then you'll need to put it in  
the root. of course, if this is the case, you'll also need to drop in  
the newer jar over the older.

- robert

On 21 Jun 2004, at 21:17, Pingili, Madhupal wrote:

> Hello All,
> I am new to this user list. I am using commons logging latest
> version which uses log4j in a web application:
>
> commons-logging.properties:
>
> org.apache.commons.logging.Log=org.apache.commons.logging.impl.Log4JLog 
> ger
>
> I have log4j.properties in the web app classpath i.e.
> /WEB-INF/classes/log4j.properties.
>
> When I deploy this web app on WebSphere 5.1, it looks like log4j is not
> initializing at all.
> It is not creating any log files for any log messages to be written.
>
> Are there any known problems with commons-logging on WebSphere 5.1?
>
> Any help is appreciated.
>
>
> Reddy Pingili
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message