commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kwan Michael <gomai...@yahoo.com>
Subject Re: [dbcp] What does it take to upgrade tomcat 4.1.27 to use dbcp 1.2.1?
Date Wed, 16 Jun 2004 20:26:11 GMT
I replaced the jar (with jars from dbcp 1.2.1 and pool
1.2).

Without changing anything on my tomcat server in which
i have a servlet accessing oracle db via oracle 9i
driver (using jndi with connection pooling), It now
becomes a 3-5 times slow down in my servlet
performance.

MK

--- Dirk Verbeeck <dirk.verbeeck@pandora.be> wrote:
> Simply replacing the jars should be enough.
> Can you create a simple testcase?
> 
> -- Dirk
> 
> Kwan Michael wrote:
> > 
> > Hi all,
> > 
> > It might be a simple question, but it sure gets me
> > thinking.
> > 
> > I m currently using tomcat 4.1.27.  I wanted to
> use
> > the pool preparedstatement from the dbcp 1.2.1. 
> So I
> > did a upgrade to replace both common-dbcp.jar with
> > common-dbcp-1.2.1.jar and common-pool.jar with
> > common-pool.jar.
> > 
> > Without doing anything to the previous
> configuration
> > (i m using JNDI datasource), I started tomcat and
> run
> > a simple jmeter test.  It turns out that my
> servlet is
> > now 3-6 times slower.
> > 
> > Am I doing the upgrade correctly?
> > 
> > YT
> 
> 
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
> commons-user-help@jakarta.apache.org
> 
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message