commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Peterson <>
Subject Re: [configuration] configuration breaks tomcat autodeploy
Date Sat, 03 Apr 2004 14:59:25 GMT
To clarify my message, the only jar left after Tomcat undeploys my app is 
the _configuration_ jar.

At 08:50 AM 4/3/2004 -0600, you wrote:

>I've just integrated the 0331 build of collections into my webapp and am 
>running into a minor glitch.  I deploy in Tomdat 5.0.18 with 
>autodeploy.  Prior to integrating collections I could do autodeploys by 
>dropping a new war file into Tomcat's appBase.
>After integrating collections, and only if I invoke the collections api, 
>autodeploy no longer works.  Inspecting the deployment directory for my 
>application, the only file left is the collections jar in WEB-INF/lib, and 
>java.exe that is running Tomcat looks like it still has the file open.  My 
>hypothesis is that some file in the jar is being referenced and not being 
>I tried expanding the jar into the WEB-INF/classes folder to force the VM 
>to read the file individually, but unfortunately the problem doesn't occur 
>in that deployment configuration.
>I'm out of ideas on how to run this down.  I know I'll get complaints on 
>Monday from the other developers on the project about autodeploy breaking, 
>so any help would be appreciated.
>To unsubscribe, e-mail:
>For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message