commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AndrewPeir...@cabs.co.zw
Subject Re: [DBCP] - Informix and DBCP 1.1 compatibility...
Date Wed, 03 Mar 2004 07:47:13 GMT
Hi Dirk,

Thanks for all the help!  At last ... success!  I have managed to get the 
example program working with the latest builds thanks to the fix that you 
provided.  The following is a summary of my findings:

Using the original, older version of the Informix JDBC driver (2.11.JC2), 
it is necessary to use the latest builds for DBCP and pool because the 
driver does not support the setReadOnly() method.  However, i have also 
downloaded the latest Informix JDBC driver (2.21.JC5) and tested it with 
the original DBCP 1.1 and pool 1.1.  It also seemed to work fine, even 
though the documentation with it explicitly states that it still does not 
support the setReadOnly() method 
see 
http://www-306.ibm.com/software/data/informix/pubs/library/220sdk/jdbc14/program.fm10.html#129139



Anyway, using the latest builds with the new driver seems to be the best 
option for anyone with similar problems...

Thanks again for all the help Dirk,

Cheers,
Andrew Peirson.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message