commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kundrot, Steven" <Steven.Kund...@perceptive.com>
Subject commons-dbcp: Problem with 2 JNDI datasources of type PerUserPoo lDataSource
Date Mon, 29 Mar 2004 16:56:58 GMT
In using version 1.1 of commons-dbcp.jar, I was attempting to deploy two
instances of the same web application (ie. war), within the same tomcat
instance, but with different database parameter information.  I configured
my tomcat with two separate context.xml files in the webapps directory.
Each context.xml registered a separate path, docbase, and JNDI datasources.
Only one of the applications worked and it was the application that
leveraged its PerUserPoolDataSource first.  When the second application
attempted to get a connection a NamingException was thrown that complained
about looking up the appropriate datasource.  Interestingly, the
NamingException throw in the second application complained that it couldn't
look up the 1st applicaiton's datasource.  The second application shouldn't
even know about the first one.

I initially thought this was a problem in our code and spent several hours
debugging through it.  After I couldn't find the issue, I updated to the
latest nightly build of commons-dbcp.jar and viola the issue was fixed.  I
tried searching the bug logs and change log of CVS for any reference to this
type of problem, but my search failed.

Does anyone know if this issue was reported and fixed?  Or did the fix
happen as a side effect of something else?

Thanks,
Steve


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message