commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Kersten" <Martin.Kers...@Student.Uni-Magdeburg.DE>
Subject Re: [Digester] Eclipse problem
Date Mon, 01 Mar 2004 19:04:52 GMT
Hi Stephen,


> Do you have the digester jar in your project classpath within Eclipse?  
I am developing an plugin. The jars are added using an seperated library
plugin. It works when I am running it using the normal JUnit. But 
running the plugin within a runtime-workspace or to run JUnit for Plugins
it fails. The Digester classes can not create the required classes of the
current plugin depending on the library plugin. 

I am using Eclipse 3.0 M7 by the way.
> Were you running JUnit within something like an Ant target with its own
> classspath?
The plain JUnit works but the JUnit for plugins don't work.

> >   I am importing digester into eclipse using an library plugin 
> > (just adding digesterXX.jar). I can run my plugin testcode
> > nicely using normal JUnit but using Plugin-JUnit or starting
> > the plugin within a eclipse platform context fails.
> > 
> > It says Digester is unable to found my implementation 
> > classes provided using a setObjectCreate rule.
> > 
> > Q1: Does anyone managed to use digester within a eclipse 
> > plugin?
> > Q2: How?
> > 
> > 
 Thanks,

Martin (Kersten)


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message