commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From meissa.Sa...@assetmanagement.natexis.fr
Subject problem with migration to dbcp 1.1.
Date Tue, 24 Feb 2004 13:56:17 GMT

Hi all,

I'm using Tomcat 4.1.18
I've tried to upgrate to the latest release of dbcp.
For this purpose, I'v downloaded the latest release and
put it in Tomcat common/lib directory.

The configuration is done within Tomcat server.xml file.
here is an extract of my file.

<Resource name="jdbc/atlas" auth="Container"
                        type="javax.sql.DataSource"/> 
 
        <ResourceParams name="jdbc/atlas">
 <parameter><name>username</name><value>XXXX</value></parameter>
            <parameter><name>password</name><value>XXX</value></parameter>
            <parameter>
              <name>removeAbandoned</name>
              <value>true</value>
            </parameter>
            <parameter>
              <name>removeAbandonedTimeout</name>
              <value>5</value>
            </parameter>
            <parameter><name>driverClassName</name>
              <value>com.sybase.jdbc2.jdbc.SybDriver</value></parameter>
            <parameter><name>url</name>
 <value>jdbc:sybase:Tds:XXXXXXXX:4100/produits</value></parameter>
          </ResourceParams> 

Everything worked         fine with the older release.

But now that I've put the new one, I'm getting exceptions like below
Caused by: java.lang.NoSuchMethodError: 
org.apache.commons.pool.impl.GenericObjectPool: method <init>()V not found
        at 
org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:765)
        at 
org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.java:518) 


Can someone explains me how to go to the new release ?
Is there something that I'm doing wrong ?

Any suggestion would be greetly appreciated. 
 
          
_______________________________________________
NATEXIS ASSET MANAGEMENT
Meissa SAKHO 
01 58 19 45 71. . . . . . . . . . . . (84571)
meissa.sakho@assetmanagement.natexis.fr

L'integrite de ce message n'etant pas assuree sur internet, Natexis
Banques Populaires ne peut etre tenu responsable de
son contenu. Toute utilisation ou diffusion non autorisee est
interdite. Si vous n'etes pas destinataire de ce message, merci de le
detruire et d'avertir l'expediteur.

The integrity of this message cannot be guaranteed
on the Internet. Natexis Banques Populaires can not therefore be
considered responsible for the contents.Any unauthorized use or dissemination is prohibited.
If you are not the intended recipient of this message, then please delete it and 
notify the sender.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message