commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hertenstein Alain" <alhertenst...@gva.eri.ch>
Subject [FileUpload] FileUploadException
Date Thu, 19 Feb 2004 15:23:47 GMT
Hi to all,

I've used until now the "fileupload 1.0rc1" API successfully on a Tomcat
4.1.12 server (WinNT). Uploading form fields and files of any size from
a JSP form worked perfect.
Now I'm deploying the exact same webapps (thus same JSP pages and API
package) for production on another Tomcat Server (4.1.24), which this
time uses a JK2 connector with an IIS Server. The upload of fields works
fine.
But when I try to upload files (jpg files allowed only) on this new
setup, it seems that files lower than ca. 54 KB can be uploaded
successfully, while files greater in size cannot be uploaded at all. I
get that exception :

org.apache.commons.fileupload.FileUploadException: Processing of
multipart/form-data request failed. Stream ended unexpectedly

It seems to happen while parsing the request
(upload.parseRequest(request)).

I've upgraded to the latest version (fileupload 1.0 final, June 2003) :
still the same error. Changing the init parameters (sizethreshold,
sizemax, etc) doesn't seem to make any difference either.
I've looked through the list archives and bug reports for the FileUpload
API, but I cannot find any solution to this problem.

Please can you help me ? Thanks a lot.
Best regards,
Alain


**********************************************************************
 This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.
**********************************************************************


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message