commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <ggreg...@seagullsw.com>
Subject RE: [vfs] problem with multiple Ant <v-copy>'s to the same filena me
Date Fri, 26 Dec 2003 23:39:39 GMT
Hello,

I've tried to duplicate a simple version of this problem in a unit test in
but could not simulate this problem (See
ProviderWriteTests.testOverwriteSameFileSystem method in CVS or the next
build). Perhaps you could provide a standalone test case?

Thanks,
Gary

PS: I am not one of the original developers of VFS but we are planning on
using VFS here at work, so have been looking at the innards and fixed one or
two very minor things.

> -----Original Message-----
> From: Jacob Kjome [mailto:hoju@visi.com]
> Sent: Monday, December 22, 2003 11:05
> To: commons-user@jakarta.apache.org
> Subject: [vfs] problem with multiple Ant <v-copy>'s to the same filename
> 
> I'm using the <v-copy> task to download files from http and ftp sites.
> This
> seems to work find, except that if I have multiple <v-copy> tasks copying
> to
> the same destfile (which gets deleted after each run, BTW), I get the
> following
> error...
> 
>      [echo] /java/repository/commons-beanutils-1.6.1/commons-beanutils.jar
> [vfs:v-copy] Copying
> http://archive.apache.org/dist/jakarta/commons/beanutils/bi
> naries/commons-beanutils-1.6.1.tar.gz to file://C:/java/repository/aFile
>    [gunzip] Expanding C:\java\repository\aFile to
> C:\java\repository\aFile.tar
>     [untar] Expanding: C:\java\repository\aFile.tar into
> C:\java\repository
>    [delete] Deleting: C:\java\repository\aFile.tar
>    [delete] Deleting: C:\java\repository\aFile
>      [echo] /java/repository/commons-collections-2.1/commons-
> collections.jar
> [vfs:v-copy] Copying
> http://archive.apache.org/dist/jakarta/commons/collections/
> binaries/collections-2.1.tar.gz to file://C:/java/repository/aFile
> 
> BUILD FAILED
> C:\myclasses\repository\TheHartford\CEII\NBS\build.xml:373: Following
> error occu
> red while executing this line
> C:\myclasses\repository\TheHartford\CEII\NBS\utility-targets.incl:187:
> Could not
>  copy file
> "http://archive.apache.org/dist/jakarta/commons/collections/binaries/
> collections-2.1.tar.gz" to "file://C:/java/repository/aFile" because the
> destina
> tion file is read-only.
> 
> 
> The destination file "aFile" is deleted, so why is <v-copy> reporting it
> to be
> existing and, apparently, "read-only"?  Does it have something to do with
> the "caching" problem reported at this thread?
> http://marc.theaimsgroup.com/?l=jakarta-commons-user&m=106786840807527&w=2
> 
> If I run Ant again, then it can download the file it failed on before, but
> then
> it craps out again if it has to download another.  So, essentially, If I
> have
> 20 files to download, I have to run the Ant build 20 times to get all the
> files.  That't obviously a bug.  Is this a known issue?  Is it going to be
> fixed soon?
> 
> The VFS tasks seem awesome, but I can't use them given this current bug.
> Can
> it be fixed soon?
> 
> Jake
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message