commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <craig...@apache.org>
Subject Re: Commons-Logging NullPointerException
Date Tue, 14 Oct 2003 16:10:54 GMT
Victor Batista wrote:

>Hello!
>	I am having some problems using Commons-Logging. I think this is a class
>loading issue. Any help would be welcome.
>
>	When I run my program, which uses commons-logging indirectly (My program
>uses the Quartz package, which uses commons-logging), everything works fine
>on Windows and Linux (7.2 & 9.0). Now I have developed a watchdog module,
>and my application is launched through it. The Watchdog uses the
>Class.forName(...) to create the instance of my original application. With
>this combination, I get the exception which is at the end of the email, only
>on RedHat 9.0 (On Windows and RedHat 7.2 everityhing works fine). I have
>tried with J2SDK 1.4.1, 1.4.2 and 1.4.2_01.
>
>     Any help would be really appreciated. Thanks in advance,
>

It would help if you told us which version of commons-logging you are 
using :-).  It appears not to be 1.0.3 (because line 558 is in the 
middle of a declaration), so upgrading to that is the first piece of advice.

It is also important to know which underlying logging system you are 
trying to use (I presume you want to use JDK 1.4 logging, because the 
JVMs you quote are all 1.4.x), an any configuration properties you are 
setting.

>		Victor Batista
>  
>
Craig

>
>* Nested Exception (Underlying Cause) ---------------
>org.apache.commons.logging.LogConfigurationException:
>java.lang.NullPointerException
>        at
>org.apache.commons.logging.LogFactory.newFactory(LogFactory.java:558)
>        at
>org.apache.commons.logging.LogFactory.getFactory(LogFactory.java:355)
>        at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:390)
>        at org.quartz.core.QuartzScheduler.getLog(QuartzScheduler.java:188)
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: commons-user-help@jakarta.apache.org
>  
>



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message