commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Geary <sabrew...@earthlink.net>
Subject [hivemind] service-point not expected in module?
Date Fri, 17 Oct 2003 02:32:42 GMT
I've cut and pasted the bootstrap example, but I get this exception  
when I run it:

run:
      [echo] Adding 11 and 23, should get 34.
      [java] Oct 16, 2003 8:06:40 PM  
org.apache.commons.hivemind.impl.RegistryBuilder$DefaultErrorHandler  
handleModuleParseError
      [java] SEVERE: Unable to parse module deployment descriptor  
jar:file:/Users/david/lab/hivemind-lab/simple/target/hivemind- 
examples.jar!/META-INF/hivemodule.xml: Unable to read descriptor  
jar:file:/Users/david/lab/hivemind-lab/simple/target/hivemind- 
examples.jar!/META-INF/hivemodule.xml: Unexpected element service-point  
within module (at  
jar:file:/Users/david/lab/hivemind-lab/simple/target/hivemind- 
examples.jar!/META-INF/hivemodule.xml, line 4).
      [java] org.apache.commons.hivemind.ApplicationRuntimeException:  
Unable to read descriptor  
jar:file:/Users/david/lab/hivemind-lab/simple/target/hivemind- 
examples.jar!/META-INF/hivemodule.xml: Unexpected element service-point  
within module (at  
jar:file:/Users/david/lab/hivemind-lab/simple/target/hivemind- 
examples.jar!/META-INF/hivemodule.xml, line 4).
      [java]     at  
org.apache.commons.hivemind.parse.DescriptorParser.parse(DescriptorParse 
r.java:480)
      [java]     at  
org.apache.commons.hivemind.impl.RegistryBuilder.processModuleResource(R 
egistryBuilder.java:245)
      [java]     at  
org.apache.commons.hivemind.impl.RegistryBuilder.processModules(Registry 
Builder.java:212)
      [java]     at hivemind.examples.Main.main(Unknown Source)
      [java] Exception in thread "main"  
org.apache.commons.hivemind.ApplicationRuntimeException: Registry does  
not contain module 'hivemind.examples'.
      [java]     at  
org.apache.commons.hivemind.impl.RegistryImpl.getModule(RegistryImpl.jav 
a:115)
      [java]     at  
org.apache.commons.hivemind.impl.RegistryImpl.getService(RegistryImpl.ja 
va:125)
      [java]     at hivemind.examples.Main.main(Unknown Source)
      [java] Java Result: 1

Evidently, the parser doesn't expect a <service-point> within <module>?  
Here's my hivemodule.xml, straight from the example:

<?xml version="1.0"?>

<module id="hivemind.examples" version="1.0.0">
    <service-point id="Adder" interface="hivemind.examples.Adder">
       <create-instance class="hivemind.examples.impl.AdderImpl"/>
    </service-point>
</module>

Does anybody know what's wrong? I'm using 1.0 alpha 2.

Thanks,


david


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message