commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Wannheden" <knut.wannhe...@paranor.ch>
Subject [HiveMind] problems running bootstrap tutorial
Date Sat, 27 Sep 2003 19:42:32 GMT
Hi,

I just got interested in the HiveMind project and wanted to run through one
of the tutorials. The bootstrap tutorial at
http://jakarta.apache.org/commons/sandbox/hivemind/bootstrap.html shows a
hivemodule.xml sample with a <service-point> element nested inside the
<module> element.  When I recreate and run that application, however, I get
the following error:

org.apache.commons.hivemind.ApplicationRuntimeException: Unable to read
descriptor
file:/D:/Projects/test/workspace/hivemind-test/bin/META-INF/hivemodule.xml:
Unexpected element service-point within module (at
file:/D:/Projects/test/workspace/hivemind-test/bin/META-INF/hivemodule.xml,
line 5).
at
org.apache.commons.hivemind.parse.DescriptorParser.parse(DescriptorParser.ja
va:480)
at
org.apache.commons.hivemind.impl.RegistryBuilder.processModuleResource(Regis
tryBuilder.java:245)
at
org.apache.commons.hivemind.impl.RegistryBuilder.processModules(RegistryBuil
der.java:212)
at hivemind.examples.impl.Main.main(Main.java:33)

It seems like the version I'm using (1.0-alpha-2, as indicated in the
tutorial) doesn't accept the <service-point> element. But after looking at
the source and changing it to <service> it all works. Is it the tutorial
which isn't up-to-date or is it even ahead of the implementation? Anyway, I
suppose it should be fixed.

I'm looking forward to future developments of HiveMind. Keep up the good
work!

--
knut




---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message