commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Libbrecht <p...@activemath.org>
Subject Re: Jelly: Need Help Installing
Date Wed, 13 Aug 2003 08:23:11 GMT
Mark Cohen wrote:
> I am using Maven 1.0 Beta 10.  I think I found my problem.  
 > As suggested, by commenting out the <extend> element in the jelly
 > project.xml file it seemed to compile OK.

Note that you shouldn't need to ignore test-results!
(at least for the core, I think some tags still have failing tests).

However, I suspect there are other problems because
 > I cannot get any of the demo scripts to run (i.e. demo:swing).
 > Maven cannot find the demo goal, it does not appear to be in
 > the project.xml file.

maven demo:swing has to be done from jelly-tags/swing directory, yet 
another documentation missing.
That's exactly the current poor situation of Jelly: the tag-libraries 
splitting from the main-project has been mainly done at the code and 
build level but is missing at the documentation-level....

> java.lang.LinkageError: loader constraints violated when linking org/xml/sax/XMLReader
class

This is probably because you don't have the appropriate classpath.
If you brows the archive about a month ago, I've posted bits from a 
project that will be called "jellypack" which generates the classpath 
for you.

Hope that helps.

Paul


Mime
View raw message