commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Cohen" <markcohenm...@earthlink.net>
Subject Re: Jelly: Need Help Installing
Date Wed, 13 Aug 2003 01:58:17 GMT
Thanks, I got it to compile!  I think the key was to comment out the <extend> element.
 I was getting an error because this element was pointing to ../project.xml but that file
is in the current directory not the parent.  I had changed this element to point to ./project.xml
to get it to run, but I suspect this was the cause of my problems.  When I commented out the
<extend> element and used the skip.tests variable you suggested, the compile completed.

Now the question is how do I get a simple Jelly script to run?  I tried running a script by
putting the required jars in my class path and running org.apache.commons.jelly.Jelly but
I get the following error:

java.lang.LinkageError: loader constraints violated when linking org/xml/sax/XMLReader class

Any idea what is the correct way to run a simple Hello World script?  Also, what is the minimal
set of JAR files required to use the jelly-core?  Would they be all the JARs in the jelly/target/lib
folder?  That seems like overkill for a minimal Jelly script?

Thanks,
Mark

----- Original Message ----- 
  From: Paul Libbrecht 
  To: Jakarta Commons Users List 
  Sent: Tuesday, August 12, 2003 7:46 PM
  Subject: Re: Jelly: Need Help Installing


  Mark,

  I'm surprised that you couldn't compile.
  Which version did you grab ?
  I would recommend to follow the cvs-checkout.
  At least on this, after commenting out the "<extend>" element, "maven 
  jar" builds fine by me (including tests).

  For taglibs, the problem will come a bit later that some dependencies 
  are not distributable as easily hence need manual work...

  Paul


  Mark Cohen wrote:
  > I am a college professor with plans on covering Jelly in my "structure of programming"
course this fall.  I have spent the entire day trying to install Jelly without success.  Following
the directions, I installed Maven and fetched the most recent version of Jelly from CVS. 
Next, I ran "maven test", and after a few of the jar files downloaded into the repository
I got a NullPointerException.  I tried several things after this (I will not go into the details)
and I still have not be able to get a working copy of Jelly.
  > 
  > Can anyone help me get Jelly installed?  Also, what is the bare minimum that can be
installed in order to just use Jelly's core functionality?  I would like to make it as simple
as possible for my students to install and start using Jelly.
  > 
  > Thanks in advance,
  > Mark Cohen
  > Instructor - Computer Science Department
  > Lock Haven University
  > 



  ---------------------------------------------------------------------
  To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
  For additional commands, e-mail: commons-user-help@jakarta.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message