commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geert Van Damme" <>
Subject Re: Ftp directory listing on NT server
Date Wed, 30 Jul 2003 13:23:00 GMT

Thanks for the info. We've decided to use the 1.0.1 version as it seems to work without any
problems. This looks like a 'cleaner' solution :)

But thanks anyway !

>>> 07/30/03 01:24pm >>>

We've stumbled upon the following with MS ftp servers:

ftp> site DIRSTYLE

this will toggle MSDOS-like directory output on or off.  You'll get the 200 reply and a message
indicating it is on or off.  I believe the default setting can also be changed at the server.
 Turning it off allows the default parser to work.

Good luck.

Geert Van Damme <> writes:

> Ok, in the meantime I've tried using the NTFTPEntryParser (latest nightly build) and
this seems to work.
> Other questions still remain... especially the last question.
>>>> 07/30/03 10:37am >>>
> Hi all,
> I'm trying to get a directory listing from an NT4 ftp server, but it returns null. I'm
using the commons-net-1.0.0 library.
> I suppose the problem is that the ftp server returns a 'windows style' listing, while
I need a 'unix style' listing.
> Is there a way to solve this ? I don't think the server accepts SITE commands (is there
any good doc somewhere about SITE ?).
> Will the NTFTPEntryParser solve my problem ? If so, is the 1.0.1-dev stable enough to
use in a production environment ?
> Thanks in advance,
> Geert
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: 
> For additional commands, e-mail: 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: 
> For additional commands, e-mail: 

Jeffrey D. Brekke                          
Wisconsin,  USA                            

To unsubscribe, e-mail: 
For additional commands, e-mail: 

View raw message