commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shaun Kenny <>
Subject FileUpload 1.0 with Tomcat 4.1.24
Date Thu, 31 Jul 2003 13:52:50 GMT

I've been trying to setup a web application using the Commons FileUpload 1.0
with Tomcat 4.1.24;  the servlet using FileUpload will compile (using
NetBeans 3.5) but when Tomcat processes it, a ClassNotFoundException is
thrown saying javax.servlet.ServletInputStream can't be found.  This
exception is traced to the following line:
	DiskFileUpload fileupload = new DiskFileUpload();
However, in the servlet, I *can* create an instance of ServletInputStream
like this:
	ServletInputStream srvin = ServletRequest.getInputStream();
This line of code compiles without problems and is executed, no problem, in
the servlet by Tomcat.  So it seems that only the FileUpload stuff can't
find the ServletInputStream class.  I've tried putting the FileUpload .jar
in the WEB-INF/lib directory of the webapp, as well as my Tomcat/common/lib
and jdk/jre/lib/ext (which Tomcat uses) directories.

However, when I uninstalled Tomcat 4.1.24 and installed Tomcat 4.1.18
everything worked fine  without changes.

Any ideas?

Shaun Kenny

View raw message