commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhino" <rhi...@sympatico.ca>
Subject [FileUpload] Installing in Eclipse
Date Thu, 10 Jul 2003 21:20:12 GMT
Can anyone tell me how/where to install FileUpload so that it works in Eclipse?

I am running Eclipse on Windows XP and have Tomcat 4.1.24 and Sysdeo V2.1 installed on my
system. Every time I run my simple file upload servlet, I get this (plus more stacktrace)
as the root cause in the exception that is thrown: 

java.lang.NoClassDefFoundError: org/apache/commons/fileupload/FileUploadBase

I posted about this a few days ago and tried everything that was suggested without success.
The last suggestion that I got said that I may have installed the FileUpload code incorrectly.
As a result, I downloaded and installed the new 2.1.1 version of Eclipse, migrated my projects
over to the new version of Eclipse, then tried my servlet again. I got the same error again!

I'm pretty bad at installing things so I've probably just done something boneheaded that is
obvious to everyone but me. That's why I'm posting here; maybe one of you folks can see what
I'm doing wrong.

My newest version of Eclipse is installed at D:\eclipse. The version of Tomcat used by this
new copy of Eclipse is at D:\jakarta-tomcat-4.1.24. My CATALINA_HOME environment variable
has been changed to point to D:\jakarta-tomcat-4.1.24. The commons-fileupload-1.0.jar file
is at D:\jakarta-tomcat-4.1.24\common\lib.

What do I have to do or change to make this work? I can compile fine but I can't run this
servlet at all, not even once.

This feels like a dumb question but I've been looking at docs for quite a while now and still
can't find this answered clearly anywhere.

Rhino
---
rhino1 AT sympatico DOT ca
"If you want the best seat in the house, you'll have to move the cat."
Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message