commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Payne" <dpa...@sotx.org>
Subject [logging] LogConfigurationException
Date Tue, 24 Jun 2003 19:09:21 GMT
I've scoured the web and it seems several others have had the same problem
but no solution. I was hoping ya'll might be able to help. Here's the stack
trace in my catalina.out:

org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: Class
org.apache.commons.logging.impl.Jdk14Logger does not implement Log
	at
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.ja
va:555)
	at
org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.ja
va:289)
	at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:409)
	at
org.apache.tomcat.util.log.CommonLogHandler.log(CommonLogHandler.java:97)
	at org.apache.tomcat.util.log.Log.log(Log.java:198)
	at org.apache.tomcat.util.log.Log.log(Log.java:192)
	at org.apache.tomcat.util.log.Log.log(Log.java:174)
	at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:533)
	at java.lang.Thread.run(Thread.java:536)
Caused by: org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: Class
org.apache.commons.logging.impl.Jdk14Logger does not implement Log
	at
org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryI
mpl.java:420)
	at
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.ja
va:548)
	... 8 more
Caused by: org.apache.commons.logging.LogConfigurationException: Class
org.apache.commons.logging.impl.Jdk14Logger does not implement Log
	at
org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryI
mpl.java:416)
	... 9 more


Environment:
Tomcat 4.1.18
jdk1.4.1_01
red hat linux

I've got the commons-logging.jar in my WEB-INF/lib folder. It is version
1.0.2
I've got the commons-logging-api.jar in tomcat/common/lib folder. It is
version 1.0.1

Is this the source of the problem? I'm not using junit or cactus which is
where most people seem to be running into this problem. I am using the pager
taglib from JspTags.com and I think it is related to the problem although
not sure. The problem isn't replicable and has only occurred three times in
the last 4 months on our production server, but it crashes Tomcat when it
does occur. Anyone have any idea what's going on?

Thanks,

Dan


Mime
View raw message