commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Goodin" <m...@phase.ws>
Subject RE: [Logging] Standalone App using BeanUtils getting wierd exception
Date Mon, 28 Apr 2003 16:27:47 GMT
I ran it standalone... same error. Also, I did have the setting as you
suggested. My posting put a linebreak right at Simple <break> Log whick is
actually org.apache.commons.logging.impl.SimpleLog in my configuration. So,
my config was right and my standalone still throws the same error.

Brandon Goodin
Phase Web and Multimedia
PO Box 85
Whitefish MT 59937
P (406) 862-2245
F (406) 862-0354
mail@phase.ws
http://www.phase.ws


-----Original Message-----
From: Craig R. McClanahan [mailto:craigmcc@apache.org]
Sent: Monday, April 28, 2003 10:01 AM
To: Jakarta Commons Users List
Subject: RE: [Logging] Standalone App using BeanUtils getting wierd
exception




On Mon, 28 Apr 2003, Brandon Goodin wrote:

>
> I am running this app in eclipse 2.1 at this point simply because it is
> still in development. Is eclipse interferring?
>

Likely so, if Eclispe is doing something wierd when it sets up the class
loader hierarchy for your app.  To assist in debugging things, you should
try running the app *really* standalone, to see if the behavior is
different.

> Anyways, let's forget about Log4j and just try to get SimpleLog working.
> BTW I DO have the most current Commons-Logging and I have the most current
> BeanUtils (and Log4j 1.2.8 but, that doesn't matter at this point).
>
> I placed a properties file in my called commons-logging.properties where
it
> is visible to my app.
>
> I set this property in the commons-logging.properties:
>
org.apache.commons.logging.LogFactory=org.apache.commons.logging.impl.Simple
> Log
>

This is not the right setting -- try the following:

  org.apache.commons.logging.Log=org.apache.commons.logging.impl.SimpleLog

Note that the property name ends in "Log", not "LogFactory" -- you really
do want to use the default LogFactory implementation, just not the default
Log implementation.

Craig

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org



Mime
View raw message