commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric_Schwarzenb...@Classwell.com
Subject Re: [jelly]Jelly compile problems
Date Mon, 17 Mar 2003 19:09:51 GMT

Likewise. Trying to use the "Getting started" info on the jelly site is an
exercise in frustration. It also still says that the jelly source is in
jakarta-commons-sandbox which also sent me on a wild goose chase when I
thought to try it with a fresher set of source.





|---------+---------------------------->
|         |           "Frank Meijer"   |
|         |           <meijer@nortelnet|
|         |           works.com>       |
|         |                            |
|         |           03/17/2003 01:30 |
|         |           PM               |
|         |           Please respond to|
|         |           "Jakarta Commons |
|         |           Users List"      |
|         |                            |
|---------+---------------------------->
  >-----------------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                                |
  |       To:       commons-user@jakarta.apache.org                                      
                                |
  |       cc:                                                                            
                                |
  |       Subject:  Re: [jelly]Jelly compile problems                                    
                                |
  >-----------------------------------------------------------------------------------------------------------------------|




I encountered the same problem as Roger Nye.  Cleaning out the
commons-discovery jar does not help :-(

...Frank
---------------------------------------------
Frank Meijer          Nortel Networks, Ottawa
---------------------------------------------



Roger Nye wrote:


Hi,
I am trying to install Jelly using Maven, having never used either of these
before and am not getting very far.

I downloaded the zipped distribution versions of Jelly 1.0-beta-3 and maven
1.0-beta-8.

extracted maven and jelly to directories, set up the environment variables
and path as specified in Getting Started.
Then ran "maven test" from the jelly directory.
It downloaded a number of jars, but then started giving messages such as:

java:prepare-filesystem:
   [mkdir] Created dir: D:\Java\commons-jelly-1.0-beta-3\target\classes

java:compile:
   [javac] Compiling 222 source files to
D:\Java\commons-jelly-1.0-beta-3\target\classes
D:
\Java\commons-jelly-1.0-beta-3\src\java\org\apache\commons\jelly\impl\Defa
ultTagLibraryResolver.java:59: cannot resolve symbol
symbol  : class ServiceDiscovery
location: package discovery
import org.apache.commons.discovery.ServiceDiscovery;
                                   ^
D:
\Java\commons-jelly-1.0-beta-3\src\java\org\apache\commons\jelly\impl\Defa
ultTagLibraryResolver.java:60: cannot resolve symbol
symbol  : class ServiceInfo
location: package discovery
import org.apache.commons.discovery.ServiceInfo;
                                   ^
D:
\Java\commons-jelly-1.0-beta-3\src\java\org\apache\commons\jelly\impl\Defa
ultTagLibraryResolver.java:83: cannot resolve symbol
symbol  : class ServiceDiscovery
location: class org.apache.commons.jelly.impl.DefaultTagLibraryResolver
   private ServiceDiscovery discovery;
           ^

and so on for 41 compile errors.

I am using Java SE 1.4.1_01-b01 on Windows 2000 Prof.


Any suggestions?
Many thanks
Roger






Mime
View raw message