commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Moseley <...@covalent.net>
Subject Re: [beanutils] setProperty problem with indexed nested property
Date Wed, 19 Feb 2003 22:58:47 GMT
robert burrell donkin wrote:
> hi Brian
> 
> i've tried to create a test case to see if it's a beanutils bug - but i 
> can't seem to make it break. this might be because this is caused by a 
> bug which has since been fixed, it could be because i don't have enough 
> information to create a good test case which demonstrates the bug - or 
> it could be that there isn't a problem with beanutils.
> 
> if you're not using the latest beanutils version (1.6.1) please upgrade 
> and retry.
> 
> if this doesn't work, then please create a small scale test where you 
> call beanutils.setProperty "ip[0].address" directly on your beans. if 
> this doesn't work, then please distill a test case (which you're happy 
> to contribute to apache) and i'll fix the bug.
> 
> if your problem is still present with 1.6.1 but doesn't manifest itself 
> outside structs then please ask again and we can look at integration 
> issues.

robert, thanks for the comments. i'm fairly sure that i'm using 1.6.1, 
but i'll verify.

i'm glad to hear that beanutils seems to have the ability to do what i'm 
asking of it. as this is the first time i've worked with indexed nested 
properties, it's very likely that the problem is pilot error; i was just 
hoping that somebody could look at the data i provided and call out an 
obvious problem.

in any case, i will put together a test and then get back to you. thanks 
again.


Mime
View raw message