commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Keyes <j...@mac.com>
Subject Re: AW: [CLI] RESEND: Inconsistency in Options.hasOption(String)
Date Tue, 18 Feb 2003 15:56:46 GMT
Hi Jörg

<snip/>

> IMHO it should throw an error in that case as a combination like that
> is far away from beeing user-friendly... But as user-friendlyness
> might be a "personal thing" you could do it as you said: take a hyphon
> or two to make it clear. But I personally would prefer the first
> solution...
I haven't decided what to do here yet.  But I take on board what
you are saying.

> Another thing I mailed you about a while ago (and also sent a testcase
> (which worked for whatever reason)):
> Can your new option handle something like that:
> 
> Option a = OptionBuilder.hasArg(true).create( "b", "begin" );
> Option a2 = OptionBuilder.create( "1" ); // begin at step 1
> Option create = OptionBuilder.create( "create", "createArchive" );
> 
> And then call the app with -b 1
> 
> This throws "no argument for b" in the last version I tried for
> whatever reason. I had no time to look at the source yet but I think
> that is because 1 is an option, too.
Don't know how I missed this.  I have it marked now anyway so I'll
keep you in the loop.

-John K



Mime
View raw message