commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Nichols <nx10m...@yahoo.co.uk>
Subject [jelly] Refactoring weirdness
Date Tue, 28 Jan 2003 22:49:59 GMT
Jelly-oids,

The current refactoring is causing me some head-scratching - am I doing 
something wrong? I'm trying to use BeanTagLibrary (thanks to Christian et 
al for pointers) and all was progressing well - except for some peculiar 
warnings when running the test suite
src/test/org/apache/commons/jelly/bean/TestJelly
-- from memory, [WARN] messages that Customer bean was not being added to a 
parent.

After a cvs up -Pd (and some disk thrashing) I no longer have access to 
BeanTagLibrary - it seems it's now in a separate jar (excellent) which I am 
unable to build (less excellent).

I can build CVS HEAD fine from the jelly dir with
cvs up -Pd
maven clean:clean
maven java:jar

But building the Bean jar breaks for me. I tried
cd [jellydir]/jelly-tags/bean
maven java:compile

which breaks with

[ERROR] java.io.FileNotFoundException: 
/home/thomasn/dev/jakarta-commons-sandbox/jelly/jelly-tags/bean/${basedir}/../tag-project.xml

(No such file or directory)

Running 'ant' in this dir downloads a bunch of support jars, then throws a 
compiler error (Uncaught exception, BeanPropertyTag.java:129) which looks 
very odd to me, the exception handling looks OK.

I've also tried maven tags-build without success.

What else can I try? BeanTags are exactly what I was looking for, is Jelly 
in such a state of flux that I should hold off developing to it until the 
API is more stable, or am I doing something very wrong? Would I be better 
with a binary distro until the refactoring is complete?

Thanks,
Thomas.


Mime
View raw message