commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Morgan Delagrange <>
Subject Re: [jelly] Refactoring weirdness
Date Tue, 28 Jan 2003 23:32:01 GMT
AFAIK the build is currently stable.  If you want the
most recent versions of jelly and the bean taglib, you
could grab them from last night's gump run:

With regard to your build problem and Maven, my best
guess is that either your Maven bootstrap is too old
(even a week would not work, welcome to Maven) or the
ibiblio repository of Jelly jars is out of date.  Out
of date ibiblio jars would also explain your Ant

Here's another script you can try from the jelly
directory, which will build Jelly, bean, and its
dependencies from HEAD from scratch.  (Let me know if
it works.  :)

  cd jelly
  ant -f build-all.xml clean-skiplib jar-bean

or you can try editing your maven environment to build
everything from scratch, if you prefer using Maven.  I
think (don't quote me on this) that you would need to:

  cd jelly
  maven clean jar:install-snapshot
  <edit maven.xml to use the jar:install-snapshot
target for tags-build>
  maven tags-build

That build will actually build ALL the tags, rather
than just bean and its dependencies.

- Morgan

--- Thomas Nichols <> wrote:
> Jelly-oids,
> The current refactoring is causing me some
> head-scratching - am I doing 
> something wrong? I'm trying to use BeanTagLibrary
> (thanks to Christian et 
> al for pointers) and all was progressing well -
> except for some peculiar 
> warnings when running the test suite
> src/test/org/apache/commons/jelly/bean/TestJelly
> -- from memory, [WARN] messages that Customer bean
> was not being added to a 
> parent.
> After a cvs up -Pd (and some disk thrashing) I no
> longer have access to 
> BeanTagLibrary - it seems it's now in a separate jar
> (excellent) which I am 
> unable to build (less excellent).
> I can build CVS HEAD fine from the jelly dir with
> cvs up -Pd
> maven clean:clean
> maven java:jar
> But building the Bean jar breaks for me. I tried
> cd [jellydir]/jelly-tags/bean
> maven java:compile
> which breaks with
> [ERROR] 
> (No such file or directory)
> Running 'ant' in this dir downloads a bunch of
> support jars, then throws a 
> compiler error (Uncaught exception,
> which looks 
> very odd to me, the exception handling looks OK.
> I've also tried maven tags-build without success.
> What else can I try? BeanTags are exactly what I was
> looking for, is Jelly 
> in such a state of flux that I should hold off
> developing to it until the 
> API is more stable, or am I doing something very
> wrong? Would I be better 
> with a binary distro until the refactoring is
> complete?
> Thanks,
> Thomas.
> --
> To unsubscribe, e-mail:  
> <>
> For additional commands, e-mail:
> <>

Morgan Delagrange

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

View raw message