commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Gregory (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (DBCP-518) Allow DBCP to work with old Java 6/JDBC drivers without throwing AbstractMethodError
Date Thu, 16 Aug 2018 03:53:00 GMT

     [ https://issues.apache.org/jira/browse/DBCP-518?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gary Gregory closed DBCP-518.
-----------------------------
       Resolution: Fixed
    Fix Version/s: 2.6.0

In git master.

> Allow DBCP to work with old Java 6/JDBC drivers without throwing AbstractMethodError
> ------------------------------------------------------------------------------------
>
>                 Key: DBCP-518
>                 URL: https://issues.apache.org/jira/browse/DBCP-518
>             Project: Commons DBCP
>          Issue Type: Bug
>    Affects Versions: 2.5.0
>            Reporter: Gary Gregory
>            Assignee: Gary Gregory
>            Priority: Major
>             Fix For: 2.6.0
>
>
> Allow DBCP to work with old Java 6/JDBC 4.0 drivers without throwing {{AbstractMethodError}}.
> As of version 2.5.0, DBCP uses methods from Java 7/JDBC 4.1 like {{Connection#getSchema()}}.
When DBCP tries to call this method, the JVM throws a {{AbstractMethodError}}.
> DBCP will detect this condition and use {{null}} for such schema values.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message