commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LANG-1405) Remove checks for java versions below the minimum supported one
Date Fri, 27 Jul 2018 22:06:00 GMT

    [ https://issues.apache.org/jira/browse/LANG-1405?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16560394#comment-16560394
] 

ASF GitHub Bot commented on LANG-1405:
--------------------------------------

Github user coveralls commented on the issue:

    https://github.com/apache/commons-lang/pull/338
  
    
    [![Coverage Status](https://coveralls.io/builds/18205077/badge)](https://coveralls.io/builds/18205077)
    
    Coverage decreased (-0.04%) to 95.244% when pulling **7d5a3984a893b3dd91a68cbe70211e2e58a6ff74
on larsgrefer:simplify-classUtils** into **2cc524380830ba76a9a7e60e37d726e2aaf743a9 on apache:master**.



> Remove checks for java versions below the minimum supported one
> ---------------------------------------------------------------
>
>                 Key: LANG-1405
>                 URL: https://issues.apache.org/jira/browse/LANG-1405
>             Project: Commons Lang
>          Issue Type: Improvement
>          Components: lang.*
>    Affects Versions: 3.5, 3.6, 3.7
>            Reporter: Lars Grefer
>            Priority: Minor
>             Fix For: 3.8
>
>
> The minimum java version for 3.x is java 1.7, so checks like {{SystemUtils.isJavaVersionAtLeast(JavaVersion.JAVA_1_5)}}
will always be true and are therefore redundant



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message