commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Williamson (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MATH-1455) mvn tests fail if JDK 9 is used
Date Sat, 31 Mar 2018 11:12:00 GMT
Mark Williamson created MATH-1455:
-------------------------------------

             Summary: mvn tests fail if JDK 9 is used
                 Key: MATH-1455
                 URL: https://issues.apache.org/jira/browse/MATH-1455
             Project: Commons Math
          Issue Type: Bug
    Affects Versions: 4.X
            Reporter: Mark Williamson


This is essentially the JDK9 version of MATH-1156
{code:java}
// code 
Running org.apache.commons.math4.util.FastMathTest
FastMath does not implement: public static long java.lang.StrictMath.multiplyExact(long,int)
FastMath does not implement: public static double java.lang.StrictMath.fma(double,double,double)
FastMath does not implement: public static float java.lang.StrictMath.fma(float,float,float)
FastMath does not implement: public static long java.lang.StrictMath.multiplyFull(int,int)
FastMath does not implement: public static long java.lang.StrictMath.multiplyHigh(long,long)
FastMath does not implement: public static long java.lang.StrictMath.floorDiv(long,int)
FastMath does not implement: public static int java.lang.StrictMath.floorMod(long,int)
{code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message