commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Ballet (JIRA) <j...@apache.org>
Subject [jira] [Created] (DAEMON-379) Unable to build with java-9 using ant.
Date Wed, 06 Dec 2017 10:22:00 GMT
Sébastien Ballet created DAEMON-379:
---------------------------------------

             Summary: Unable to build with java-9 using ant.
                 Key: DAEMON-379
                 URL: https://issues.apache.org/jira/browse/DAEMON-379
             Project: Commons Daemon
          Issue Type: Bug
    Affects Versions: 1.1.0
         Environment: slackware-64 14.2
openjdk 9.0.0.15
Apache Ant 1.10.1


            Reporter: Sébastien Ballet
            Priority: Minor


Build of commons-dameon with java-9 using Ant fails with the following errors :

    [javac] Compiling 10 source files to /tmp/SeB/commons-daemon-1.1.0-src/target/classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.5
    [javac] error: Source option 1.5 is no longer supported. Use 1.6 or later.
    [javac] error: Target option 1.5 is no longer supported. Use 1.6 or later.

The patch below fixes that issue :

--- build.xml.orig	2017-12-06 10:54:59.570231291 +0100
+++ build.xml	2017-12-06 10:57:14.879237328 +0100
@@ -93,10 +93,10 @@
 
 
   <!-- compiler source JDK version -->
-  <property name="compile.source"          value="1.5"/>
+  <property name="compile.source"          value="1.6"/>
 
   <!-- compiler target JDK version -->
-  <property name="compile.target"          value="1.5"/>
+  <property name="compile.target"          value="1.6"/>
 
   <!-- Should Java compilations set the 'debug' compiler option? -->
   <property name="compile.debug"           value="true"/>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message